Recopilación de Tutoriales en Español

Hola,

Voy a mantener este hilo actualizado con los manuales que vamos creando en el blog.

Instalación

Primeros pasos

Bots

N8N para SRE

Grupo de telegram

Saludos,

2 Likes

Por mi parte aportar mi experiencia con la instalación de n8n en debian 10 que creo que puede ser de utilidad para otros nuevos usuarios.

Me encontré con los errores siguientes:

npm i sqlite3 -g --build-from-source
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated request@2.88.2: request has been deprecated, see Request’s Past, Present and Future · Issue #3142 · request/request · GitHub
npm WARN deprecated node-pre-gyp@0.11.0: Please upgrade to @mapbox/node-pre-gyp: the non-scoped node-pre-gyp package is deprecated and only the @mapbox scoped package will recieve updates in the future
npm ERR! code 127
npm ERR! path /root/.nvm/versions/node/v15.12.0/lib/node_modules/sqlite3
npm ERR! command failed
npm ERR! command sh -c node-pre-gyp install --fallback-to-build
npm ERR! sh: 1: node-pre-gyp: Permission denied
npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2021-03-20T16_15_21_974Z-debug.log

Conseguí resolverlo instalando la v14.16.0 de node por un lado y para el permiso denegado de node-pre-gyp ha sido necesario aplicar la instrucción siguiente:
# npm config set user 0
dado que según he leido por internet esta situación suele ser frecuente cuando se instala como root módulos de nodo usuario que requieren compilación con node-gyp.

Después de esto pude instalar n8n correctamente.

npm install n8n -g

Un saludo,
Sergi

1 Like